Back to overview
Resolved

Release v112.4

Aug 27, 2026 at 2:00pm UTC  –  Aug 27, 2026 at 3:00pm UTC
Affected services
App
Share Link
API
Real Time

Resolved
Aug 27, 2026 at 3:00pm UTC

Maintenance ended

Created
Aug 27, 2026 at 2:00pm UTC

We are deploying IcePanel v112.4.

API changes:

  • Default actor size is incorrect when updating diagram objects
  • Improve version creation speed for large landscapes and fix new versions appearing ready before all data was copied
  • Add full text search to the catalog technologies list endpoint with the search query parameter
  • Add a catalog technologies list select endpoint that returns only the requested fields
  • Tag model object and connection ids are now derived from the model at read time and are no longer stored on tags, request them on the tag list and get endpoints with the expand query parameter

App changes:

  • Show auto version toggle even when no previous versions exist
  • Area layouts jump around when they do not contain any child objects