Back to overview
Resolved
Release v112.2
Aug 13, 2026 at 9:00pm UTC
–
Aug 13, 2026 at 10:00pm UTC
Affected services
App
Share Link
API
Real Time
Resolved
Aug 13, 2026 at 10:00pm UTC
Maintenance ended
Affected services
Created
Aug 13, 2026 at 9:00pm UTC
We are deploying IcePanel v112.2.
API changes:
- Do not create a diagram if its content fails to create
- Add webhook events for tags and tag groups
- Calculate diagram connection points automatically in the get endpoint and deprecate the connection points property
- Roll back failed merge operations automatically instead of leaving corrupted data
- Fix handling of deleted objects in drafts and prevent merges that could create invalid references
- Include the top-level entity id in validation errors
- Fix drafts failing to apply when they contain corrupt tasks
- Prevent self-looping connections and other invalid data from being saved
- Fix race conditions that could cause stale change detection during draft merges
- Include the object name in the error when an object is already in a diagram
- Throw a clear error when merging an empty draft
- Prevent duplicate model objects from being added to the same diagram
- Fix draft tasks failing to apply when entities were deleted in the main version
- Add export schema v2 matching the import schema with teams, technologies and flows, and make it the default
- Optimize fetching of model object connections and context
App changes:
- Fix error when duplicating a diagram that contains objects or connections referencing deleted model entries
- Fix modal flicker when cancelling the deletion of a comment thread
- Fix tags not loading in the model object viewer
- Add quick-start helper with create actions to empty diagrams
- Connection points on diagrams are now calculated automatically
- Fix error when opening diagram and flow context menus
- Polish organization settings screens and the share/embed dialog
- Update IcePanel logos
- Fall back to the first edited diagram when opening a draft
- Improve design of organization sharing and diagramming settings and add a "View in model viewer" menu item
- Fix comment thread closing when cancelling its delete dialog
- Add empty state with a create action to the related diagrams list
- Fix race condition that allowed objects with duplicate names to be created without an error
- Fix navigation from model objects in drafts after a merge
- Fix drafts breaking when a draft task fails to apply
- Add ID column to the API keys table
- Fix webhooks page not being visible to admins on some plans
Affected services